XZ-Utils 5.6.0/5.6.1版本后门风险(CVE-2024-3094)

admin 2024-04-01 17:58:18 Ali_nvd 来源:ZONE.CI 全球网 0 阅读模式
高危 XZ-Utils 5.6.0/5.6.1版本后门风险(CVE-2024-3094)

CVE编号

CVE-2024-3094

利用情况

暂无

补丁情况

官方补丁

披露时间

2024-03-29
漏洞描述
XZ-Utils是Linux、Unix等POSIX兼容系统中广泛用于处理.xz文件的套件,包含liblzma、xz等组件,已集成在debian、ubuntu、centos等发行版仓库中。2024年3月29日,安全社区披露其存在 CVE-2024-3094 XZ-Utils 5.6.0-5.6.1版本后门风险。该后门存在于XZ Utils的5.6.0和5.6.1版本中,由于SSH底层依赖了liblzma等,攻击者可能利用这一漏洞在受影响的系统上绕过SSH的认证获得未授权访问权限,执行任意代码。 受影响版本 5.6.0 5.6.1 注 企业主流使用的Linux发行版(例如Red Hat、CentOS、Debian、Ubuntu)的Stable稳定版未合并存在后门的版本,因此不受影响。建议客户根据实际情况进行排查。 时间线 3月29日 安全社区披露 CVE-2024-3094 XZ-Utils 5.6.0/5.6.1版本后门风险 3月30日 阿里云云安全中心支持 liblzma资产检索、漏洞检测、后门查杀与告警
解决建议
1、可使用云安全中心-主机资产-中间件功能查询进程所使用依赖的liblzma版本 或者 手动运行 xz -V 或 xz -version 获取系统安装的xz/liblzma版本。 2、若使用了受影响版本xz/liblzma的操作系统(Fedora 41、Debian sid 测试版等)建议更新至安全版本。具体详情可在查询 https://repology.org/project/xz/versions
参考链接
https://access.redhat.com/security/cve/CVE-2024-3094
https://arstechnica.com/security/2024/03/backdoor-found-in-widely-used-linux-...
https://aws.amazon.com/security/security-bulletins/AWS-2024-002/
https://bugzilla.redhat.com/show_bug.cgi?id=2272210
https://bugzilla.suse.com/show_bug.cgi?id=1222124
https://gynvael.coldwind.pl/?lang=en&id=782
https://lists.freebsd.org/archives/freebsd-security/2024-March/000248.html
https://mp.weixin.qq.com/s/4EfDRxMgX1PwKSHmsLsWsg
https://news.ycombinator.com/item?id=39865810
https://news.ycombinator.com/item?id=39877267
https://openssf.org/blog/2024/03/30/xz-backdoor-cve-2024-3094/
https://security-tracker.debian.org/tracker/CVE-2024-3094
https://security.alpinelinux.org/vuln/CVE-2024-3094
https://security.archlinux.org/CVE-2024-3094
https://www.cisa.gov/news-events/alerts/2024/03/29/reported-supply-chain-comp...
https://www.darkreading.com/vulnerabilities-threats/are-you-affected-by-the-b...
https://www.openwall.com/lists/oss-security/2024/03/29/4
https://www.redhat.com/en/blog/urgent-security-alert-fedora-41-and-rawhide-users
https://www.tenable.com/blog/frequently-asked-questions-cve-2024-3094-supply-...
https://www.theregister.com/2024/03/29/malicious_backdoor_xz/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian_10 xz-utils * Up to (excluding) 5.2.4-1+deb10u1
运行在以下环境
系统 debian_11 xz-utils * Up to (excluding) 5.2.5-2.1~deb11u1
运行在以下环境
系统 debian_12 xz-utils * Up to (excluding) 5.4.1-0.2
运行在以下环境
系统 debian_13 xz-utils 5.6.0 Up to (excluding) 5.6.1+really5.4.5-1
阿里云评分 7.5
  • 攻击路径 远程
  • 攻击复杂度 复杂
  • 权限要求 无需权限
  • 影响范围 全局影响
  • EXP成熟度 未验证
  • 补丁情况 官方补丁
  • 数据保密性 数据泄露
  • 数据完整性 传输被破坏
  • 服务器危害 服务器失陷
  • 全网数量 100
CWE-ID 漏洞类型
CWE-506 内嵌的恶意代码
- avd.aliyun.com
weinxin
版权声明
本站原创文章转载请注明文章出处及链接,谢谢合作!
评论:0   参与:  0