OpenTSDB 命令注入漏洞(CVE-2023-25826)

admin 2023-12-28 18:43:48 Ali_highrisk 来源:ZONE.CI 全球网 0 阅读模式
高危 OpenTSDB 命令注入漏洞(CVE-2023-25826)

CVE编号

CVE-2023-25826

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-05-04
漏洞描述
由于传递给旧版 HTTP 查询 API 的参数验证不充分,可能会将精心设计的操作系统命令注入多个参数并在 OpenTSDB 主机系统上执行恶意代码。 此漏洞的存在是由于此漏洞之前被披露为 CVE-2020-35476 时修复不完整。 为限制对查询 API 的允许输入而实施的正则表达式验证无法按预期工作,从而允许精心设计的命令绕过验证。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
参考链接
http://packetstormsecurity.com/files/174570/OpenTSDB-2.4.1-Unauthenticated-Co...
https://github.com/OpenTSDB/opentsdb/pull/2275
https://twitter.com/chybeta/status/1654761907432353794
https://www.synopsys.com/blogs/software-security/opentsdb/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 opentsdb opentsdb * From (including) 1.0.0 Up to (including) 2.4.1
阿里云评分 8.1
  • 攻击路径 远程
  • 攻击复杂度 容易
  • 权限要求 无需权限
  • 影响范围 全局影响
  • EXP成熟度 未验证
  • 补丁情况 官方补丁
  • 数据保密性 数据泄露
  • 数据完整性 传输被破坏
  • 服务器危害 服务器失陷
  • 全网数量 N/A
CWE-ID 漏洞类型
CWE-77 在命令中使用的特殊元素转义处理不恰当(命令注入)
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
- avd.aliyun.com
weinxin
版权声明
本站原创文章转载请注明文章出处及链接,谢谢合作!
评论:0   参与:  0